Monthly Archives: May 2010

Buggy driver of Lexmark X2670?

I bought a Lexmark X2670 printer/scanner device today. I downloaded their Debian Linux driver from Internet. When trying to install, it was firing an error message that CUPS 1.2 or above is necessary despite I have CUPS 1.4.1. After some … Continue reading

Posted in Linux/Unix | Tagged , , , , , , , | 2 Comments