Buggy driver of Lexmark X2670?

I bought a Lexmark X2670 printer/scanner device today.

I downloaded their Debian Linux driver from Internet. When trying to install, it was firing an error message that CUPS 1.2 or above is necessary despite I have CUPS 1.4.1. After some magic with the source it was installed. (Don’t ask me, search it in Internet, because I forgot where it was written. If you successfully install it, write a comment here about how to do it.)

But my Linux (version 2.6.32-3-686) has crashed twice today. I suspect that the driver is buggy.

Yes, I sent Lexmark a letter asking to make their driver open source.

Advertisements
This entry was posted in Linux/Unix and tagged , , , , , , , . Bookmark the permalink.

2 Responses to Buggy driver of Lexmark X2670?

  1. porton says:

    Oh, I found a solution how to pass over “CUPS 1.2” bug:
    http://forums.linux-foundation.org/read.php?29,11173

    You need to extract and then manually edit the source.

  2. K Onica says:

    A little off the subject perhaps, but a request for people to think about the ethics of purchasing things like compatible toners and printer ink. Do try and think about, for example, the parts your item is manufactured from, the human rights of the employees where they’re manufactured and the green credentials of retailers. Oh, and try to recycle instead of throwing away. Thanks!!!!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s